Can we please have 'no pets' included in the multi choice filter?

I’ve noticed an anomaly when trying to use the filter to say which pets I am happy to sit for.
‘No pets’ should be included in the multi-choice option but it isn’t. For example, if I am happy to sit for a homeowner with cats, dogs, fish, or those with no pets I can not use the filter because as soon as I click on ‘no pets’ cats, dogs and fish are deleted.