Anyone else unable to Login to THS website?

Quick SOS - to the Community!

I’ve been able to login to the THS website before, no problems.

Tried to login directly to the website today (rather than the app) - and it wouldn’t accept my password, (screen blinked & did nothing!)

Re-set the password, fine.

Tried to log in again, it wouldn’t ‘click’ - and the screen blinked. No notification errors (from my computers software, and none from the THS website).

Tried to complete the HELP form, with this info. It came up with an error message.

Followed links to the CHAT BOX - similar layout. Filled in the info & error message again!

How do I contact THS for tech support! Urgently need to be able to access my account.

Any help - or links would be much appreciated!

I am able to log onto both website and app today .

You can send an e-mail direct to


I can log into the website on my phone in Chrome but not in Brave Browser. App is fine.


Aha! that’s great, thank you - I was looking for a Suppport email address!

I’ll email & see if it’s my laptop settings.

:dizzy: :+1: :computer: :smiling_face:

1 Like

Ah! Very good to know.

I’ll try a different browser, I’ve been using Firefox without any probs - but maybe there’s been a glitch. Tho still find it odd that there weren’t any notification (error msgs) - just a screen blink :face_with_spiral_eyes:

Will try diff brwosers - thank you

:dizzy: :+1: :computer: :smiling_face:

1 Like

Mine Brave browser didn’t go blank. It just didn’t move from the login screen


I’m in!

With Edge

Sounds similar tech issue with Brave & Firefox (it kinda blinked - as if it couldn’t process!)

I’ll keep updating firefox and see if any changes, maybe a temporary issue - had been fine up to today.

Really appreciate the massive help from you & @Silversitters - had a minor panic this morning about accessing my full account (preping lots of tech stuff pre-flights!) - thank goodness for this Community Forum - was amazed I could even log-in to the forum!

A big thank you @Timshazz & @Silversitters

:star_struck: :clap: :ok_woman: :computer: :airplane:


It sounds like maybe it was an update on the browser you were using and gave you an SSL error. That’s usually the issue with websites not working in different browsers.

1 Like

That’s worth knowing for future! Brill - thanks Wendy :ok_woman: :clap: :computer: :+1: :dizzy:

1 Like

Hi All
I am having issues trying to access THS website. I can google the website but when I select the site, I get a message “mmmm we cannot locate the website address”! I have firefox installed and have updated and checked that it can access websites to no avail. Have updated windows and also tried Edge, Google, Firefox but still no luck. Interestingly enough, I can login to the community forum, as is obvious from this post! Any ideas? I need to complete a review for our last housesit that I know they are waiting for. Have never had this issue before! HELP somebody please :pray: :pray: :pray:

Hi @KiwiSwede and I’m sorry to hear you are having trouble accessing the THS website.

I highly recommend that you contact Membership Services by email at
and someone can look in to this issue for you.