Saved Search wrong selection

Hi, On my iPhone App the Saved Search is showing the wrong selection.

for example - If I look at my saved search Paris list shows it correctly shows me a Paris List - but then I look at my saved search list for Amsterdam and it still shows me the Paris list. I have tried deleting the searches and recreating them but I get the same. It looks like some cash is not being cleared between one search and the next. Is anyone else getting this ? Phil

@Hobbsp Welcome to the forum :slight_smile:

I’m not sure why that is happening, but it does not sound very helpful, maybe a technical glitch?

I will refer you to the Membership Service team as they can look at your account and check everything is working as it should be.

Please look out for an email from

I am experiencing same issue

@MaggieUU I will pass your details on as well, sorry for the inconvenience :slight_smile:

I wrote to Membership Support earlier today about this problem.

Should have mentioned I am on an android

@mars Thank you, they should get back to you soon and I have added your details internally as well :slight_smile:

1 Like

this happened to me today too. I closed the app and when I reopened and went to my saved search it was all fine

@Carla_C there is still a problem with the app as described above. I’m using an android tablet Samsung Galaxy Tab A8 running Android 13. If I go to my saved searches straight from the notification there is no problem. But if I then go straight on to a saved search in the app list (not via a notification) it shows me only sits that have no dates i.e. not looking for a sitter. The only way I can correct itbis to close the app & re-open then I can click on each saved search and get correct results. It seems to be something to do with first going through to the app from a notification. This only started today for me (2/8/2023). Would you please send this on to the tech team. It’s been happening all day.

Hi @Crookie Carla is offline at the moment and so I have passed this on to the tech team we will update when there is any relevant info.

1 Like

Hi @Crookie @Hobbsp @mars this has now been raised as a bug, thank you for flagging :clap:

1 Like

Having similar problems with iPhone. Reinstalled app and recreated searches to little avail.

Same here, there are a few threads about different issues at this point.

@Elaine & @jcvbva Thank you for updating us that you are also experiencing this issue.

Just in case you missed it noted above it is a known issue and has been logged as a bug by the tech team.

Thank you for everyone’s patience whilst they are dealing with this. If you need more information or would like to report it is affecting you as well please do reach out to Membership Services at

Once the bug is fixed it will resolve all of the issues, apologies I do not have a timeline on that but Membership Services will be able to assist further.

I’m having this same issue. So frustrating. As a full-timer, I rely heavily on the notifications of my saved searches.

For instance … there may be three listings when I call up a saved search. But when I enter the same criteria in a new search, many more listings are actually available! Please help … this is a major component of the site and for it not to be reliable compromises major functionality.


1 Like

Totally agree with you and it’s now been over a week since this started. Like you I rely on the notifications, I’m getting none! Very disappointed in CS attitude to it too. Wait till we fix but we don’t know when that will be it is basically their response

just logged on to forum as I have had this problem for well over a week now. And totally agree - surely in this technological age a bug should be easy to fix!

I’m having a similar issue today, but it was fine yesterday. I’m getting notifications on my iPhone 11. I click on the notification and it takes me to the saved search but the listings are from various other locations. Also, if I directly click on the saved searches to look at the latest listings, the content is again from other locations.

I don’t have any issue with viewing my saved searches on the website.

@Carla_C @Angela_L

@Snowbird I’m sorry to hear that is happening, it sounds like it might be the same bug that the tech team are investigating. Once they release a fix it should resolve it for everyone affected.

Please do reach out to the Membership Services team and let them know at as they will have more information.

Thank you :slight_smile: