Trouble with App

Just wondered if anyone else is having this problem. When I’m using the app it doesn’t show that I’m a fully paid member and I have no details on my dashboard of upcoming or past sits. I’ve tried un installing and reinstalling but still doesn’t work.


I’m having major problems with the app right now.
I’ve tried everything, including reinstalling multiple times.
I think the new version of the app is really really buggy, and needs fixin’.
(The issues I’m having are different than yours, but started last night when I updated the app, after being prompted to do so.)

1 Like

The app has been driving me mad for a week or so!! It will not save my searches so that I can retrieve the correct info. It muddles them all up. Amsterdam shows me Spain, Barcelona shows me Prague etc etc. It’s horrendous :tired_face:.


App: I look at a saved search, then try to look at another. Nothing there, no sits at all when I know there are plenty.


Hello everyone on this thread, there are a couple of other current threads that might help as there are some known bugs/technical issues that are being discussed on them:

Outside of those I am sure other forums members will help as they have been or you can contact the Membership Services team to log any issues at: or the help desk chat:

1 Like

There is not one app. There are two apps: one for iOS (iPhone etc) and one for android. Both have have issues now it seems, but different ones.

If you have problems and no laptop/desktop available, you can try to access the THS web site using a browser like Chrome on your mobile device. (But I do not succeed in that now, logging in via Facebook.)


The app has been problematic for a couple of weeks (I use an android device). I contacted membership support as recommended by @Carla and all they said was they will refer my issue to the IT dept, couldn’t tell me anything else or how long it will take to be fixed. Frankly I think we all just need to send them emails and hope the increased emails traffic gets them working on it quickly rather than stuffing around with the non urgent tweeks like pet photos.


I have a similar problem. Saved search for one city in the UK but when I open it there are sits for the entire UK. Another saved search, when I receive an alert and open it instantly, I see “No search results this time, sorry”. However, type in the city to a new search & hey presto there are results!
Like others, I have uninstalled & reinstalled the app several times but it makes no difference.

In case anyone has missed this update from Carla …

Thank goodness I thought it was just me having issues with the app (Android)! Tried contacting the help desk, no response as yet from the tech team. Sit searches either only work once then I can’t open them or they all have the same sits! Also, the ‘Anywhere’ search option has stopped working. Very frustrating when you are trying to find sits. Hope the moderators will pass on our frustrations. :+1:

I love TH but not their APP. It often blocks me from entering the inbox or from getting a specific message. This is serious as I travel a lot and am often not near a laptop or computer. Also I see that when homeowners click on the blue link that shows up when I send them my email address, the email does not go through to me. This makes me look dysfunctional when it is the TH app. Anyone else notice this?I have sent feedback to TH today about their app.

As a workaround, you can try to log in on the web interface using the browser on your mobile device.

1 Like

I guess I’m “glad” to know it is so buggy, I was thinking I was just completely inept!

1 Like

Yes, it will not recognize my password!

I had that a few weeks ago @cletap - multiple turns. I deleted and reinstalled the app and it has been a bit better. If I drop in and out of WiFi then it logs me out and can’t relou me in when I’m back within distance :flushed::flushed:

I think I have it working now, at least it recognizes the password!

Can’t log in to my page!

Hi @Kamla firstly, a very warm welcome to the Community Forum and I am sorry to hear you are having trouble logging in. Can I just check if this is on the app on your phone/iPad/tablet or on the website or both?

Yes. I have the same. I contacted support earlier this year and the said “we will pass on your feedback” and nothing happened.

I also got pretty fed up of being flooded with “upgrade your account” messages when I’d already upgraded. I mentioned that too to support while on the phone to them, and they said there was nothing they could do about that.

I pointed out that with other websites, I’ve not experienced similar problems post upgrading, so it must be possible to address it.

After that, this time around I renewed only as a basic member, as I thought what was the point? It appears that it is tricky to claim any of the additional benefits in any event, AND you still get bombarded with offers to upgrade after you have, which is super annoying. So there are only disadvantages in upgrading.

It happens a lot if you move off one WiFi to another and back again, especially on the app @Kamla