THS App Andoid


I cannot seem to access My Sits on the App …the page is just buffering with the red loveheart.

Does anyone else have this issue or know how to resolve this please.

Many thanks :pray:

1 Like

It’s working fine for me, is everything else working, that sounds like a weak Wifi fault. As a start, I would re-boot the phone

HI @jimmysmum
If it still does not work as @colin suggests, perhaps delete the App and reinstall it again.
This can often also sort out the issue.

I’m having issues all day too, no sits anywhere in the world for my saved search of dec- mar apparently :see_no_evil:. I’ve tried deleting and reinstalling and same issues.

@Elaine A very warm welcome to the forum, it’s lovely to have you here. Thank you for raising this.

That does sound odd as a quick global search and there are lots of sits available between December 2023 - March 2024. Do you have any other filters set up?

I will pass this on to the Membership Services Team as they will be able to look at your account and help you further.

Please look out for an email from

Yes I’ve a few and none of them are working properly today.

Same issue here. No sits in my saved sits at all, highly unlikely between March-July :grinning:

I can not see my sits the majority of the time in the app. Perhaps the volume? I always have to go to the website to see my sits. Same thing, just the heart.

1 Like

@Els & @lifephasenext Thank you for the update, I will pass this on to our wider team just in case there is a technical glitch, please do reach out to the Membership Service department as they will be able to look into your individual accounts. Thank you :slight_smile:

@Carla_C there is still a problem with the app as described above. I’m using an android tablet Samsung Galaxy Tab A8 running Android 13. If I go to my saved searches straight from the notification there is no problem. But if I then go straight on to a saved search in the app list (not via a notification) it shows me only sits that have no dates i.e. not looking for a sitter. The only way I can correct itbis to close the app & re-open then I can click on each saved search and get correct results. It seems to be something to do with first going through to the app from a notification. This only started today for me (2/8/2023). Would you please send this on to the tech team. It’s been happening all day.

As a side bar, the issue has happened at the same time that the tablet back arrow stopped working on the THS app. If I use the app back arrow (top LHS in the app) then no problem, but the app is no longer responding to the tablet back arrow at the bottom of the screen.

EDIT: just realised I put this on the wrong thread.


We’ve passed on to Tech @Crookie and acknowledged in the other channel

1 Like

You’re lucky you’re getting notifications at all, I’m not :sob:

What’s the other channel? Thanks

@Elaine I can help you with that :slight_smile: Here is the other topic: Saved Search wrong selection

@Elaine Saved Search Wrong Selection

Am I the only one having issues using this app on my android phone lately? It’s been imperfect but lately it’s become frustrating to use.

Yes, it’s a known bug apparently:

@Angela_L Does the tech team have any idea when this will be sorted? It’s been going on for nearly a week now…

1 Like

Yep, same here. Still having all the same issues for days now. @Angela_L what’s the update for a fix please?

@Crookie @Els … I will check with the team


I actually have an Apple phone and am having app issues since the last update I did a few days ago.

My issue is with my saved searches.

They are getting all mixed up Re content.

I have a UK saved search, Worldwide, Perth Aust, Hobart Aust etc.

I can look in the Hobart one and it will have UK content in it for eg.

When logged into site via internet though, the saved searches content is fine/ correct.

I’ve sent an email to THS about it but have no reply thus far.

And I’ve tried uninstalling and reinstalling the app and that didn’t work so I tried the same but turned phone off and on in between. That didn’t work.

Any thoughts as it is really painful and the website isn’t as easy as going into the app etc. I always have to select latest to get the latest info in the website so just not as quick as the app (when it works i.e.).