Website Not Letting Me Log In (Again)

Safari browser on iPad Pro iOS 16.5.1
The Website isn’t letting me log in. User and pwd are 100% correct (I use LastPass pwd manager but I’ve also tried disabling it and logging in the old fashioned way). THS Website is having none of it & tells me to:
:exclamation:Please enter a correct email and password. Note that password is case-sensitive.”

Anyone else, or am I just persona non grata at THS now?

I’m on an iPad Pro on 16.6 and am encountering no problems on the website via Safari.

Thanks @Maggie8K: That leads me to suspect that the iOS update is the culprit as the same happened to me last time an update was released. I will update and see.
Odd though, this never used to happen, no matter how long I took to get an update done :thinking:

Hope that fixes it. Good luck!

Mine was doing that last week. The app keeps logging me out multi times daily and then I get the wheel of death @Saltrams - we’ve missed a lot of sit notifications in the last two weeks :flushed: Support are working on it but it’s taking some time….

I need to do that latest update @Maggie8K maybe that’s the problem for me too :+1:t3:

@Cuttlefish and @Saltrams, I haven’t had problems of that sort with THS’s website or app. Generally, I stay on top of iOS and app updates.

If any problems with an app:

• Relaunch app.
• If that doesn’t work, reboot iPad.
• And if that doesn’t work, then delete app and reload it.

Don’t know whether this might help in your circumstances. Hope so.

1 Like

Tried all those @Maggie8K so going for the IOS update tonight and will report back tomorrow. Thank you. Nearly bed time in SL :sri_lanka::joy:

Done the update but still can’t log in. Reboot the Pad is the next thing but that’s a pain while I’m busy using it :angry:

Update: NOPE! Still not letting me in :face_with_symbols_over_mouth:

@Saltrams Sorry to hear you are having these login issues today. There are no general login issues reported across the site.

I know I updated my computer this week as my google chrome was out of date and it lost all of my passwords so I had to password reset all of my saved tabs. Are you able to do a password reset or have you tried that and are still locked out?

I also had to restart my device after the update so hoping your restart works!

If you continue to have issues please reach out to the Membership Service team at

Also as a side note for anyone reading (this might not apply to your situation as you are using a browser), the app is not compatible with an iPad for anyone that uses it that way.

Thanks @Carla_C but I’m not tinkering with my pwd because I’m logged in on the App and I don’t want to risk total loss of access.

That’s news to me, unless I have misunderstood you. I have the App on my Pad and it functions properly.

@Saltrams Oh that’s understandable as it will log you out of everything if you reset the password and I know that can be annoying. Maybe other forum members or Membership services will have more advice to get you back in.

I’m happy to elaborate as you mentioned I guess many people might not be aware of that. I just mentioned the app/iPad combo for any readers that might have those issues at any point as we get quite a few reaching out about app issues on an iPad.

The tech team state that we do not support the app on an iPad, it might work okay for some users, but any issues specifically with the app on an iPad they mention it is not supported and advise to use the app on a different device.

I’m glad you are one of the ones it seems to work for and I hope you get back into your account soon.

I use the iPhone app on iPad when I want to see whether a HO has reviews missing from sits. It works fine — nothing’s janky that I can tell.

For context: iPhone apps often work fine on iPad, since they share iOS. The iPhone apps just don’t fill the iPad’s larger screen.

In some cases, some functionality might be janky, but it’s usually on e-commerce apps, I’ve found. Like you won’t see some buttons or options. But I think the THS app is relatively basic and I’ve not encountered missing features or options (yet).

Oh for the “good old days” where you just logged in on a device and applied and all was good - along with the other fifty housesitters. I also had to walk ten klms to school barefoot in the snow :thinking::joy:

1 Like

We used to get a lift up the road in the bucket of a dumper truck @ziggy :joy::joy::joy: #iloved1982

LOL. I grew up on a tropical island and didn’t see snow till I went skiing in college. I did use BBSs in ye olden days, before the internet, though. I remember marveling the first time I traded msgs with a stranger online. By then, I was working in Hong Kong. I msg’d some random Norwegian. You had no idea who’d you get, because people had handles, no profiles or photos. We’d ask each other doofy stuff, like what time it was where they were. It must’ve been how people reacted when the telegraph was invented, LOL.

1 Like

Radio Hams still do that @Maggie8K!

Finally took the worst, drastic step in order to fix the problem @Cuttlefish @Carla_C; I cleared my cache :scream: (which I hate doing). However, it worked and I can now log in OK.
Of course I now have no browser history, notification settings, cookies set etc. etc. :confounded:

Glad you got things working again. Clearing cache sucks. I just had to do that for a problem with another website and app and it still doesn’t work, argh.

DAMN it’s happening again. I really don’t want to clear my cache again. I’m becoming suspicious that this is caused by travelling (ironically) and attempting to access sits/inbox/searches whilst logged-in at a different IP address.
So, I have a VPN with dedicated IP and will try with that enabled. :rage:

Edit update: VPN made no difference.

This time I cleared the cookies ONLY for (in Safari “Advanced” settings) and it worked, I can log-in again. Interestingly that also logged me out of this forum.
So, the reason for this issue is still a mystery and clearing Website data is the only solution I have found. It’s bound to happen again, so I’ll keep monitoring the circumstances.