Past sits not showing in app

Can’t see past sits on my app today - they are not in the menu anywhere- I have deleted and reinstalled app - still not there . I have contacted member services who didn’t have any other suggestions for a fix.

Is it just me or anyone else experiencing me issue ?

@Jenny it would be useful to have a section of the forum specifically for app issues .

Hi @Silversitters

I’ve passed your feedback to the team to see if they can give me any further info - and I’ve mentioned you’ve already tried MS.

I like your idea about having a place to log app issues. Bear with me for now and I’ll see what we can do.

Jenny :slight_smile:

1 Like

What does the dashboard icon look like and where do I find it ? :exploding_head:

@Silversitters So sorry - it might be easier just to share what I see, I have an iPhone using the app. The dashboard icon is a little house in the bottom left. This opens the main dashboard and you should see above it a link to your past sits. If you need more help let me know.

1 Like

Thanks @Carla I also have an iPhone - I don’t have a dashboard icon . I deleted the app and reinstalled it - I still don’t have a dashboard icon :disappointed:

I have the new brand colours but no dashboard icon.

I asked member services about this - they had no resolutions or suggestions to offer . :man_shrugging:

@Silversitters It looks the same for me (also iPhone).

Except that between “My verifications” and “Settings” I have “Reviews and references” AND “Feedback”. Those two buttons seem to lead to the same thing.

It is quite a mess. That is what members could complain a bit more about, instead of homes not being spotless.

Well I have complained direct to member services before coming to the forum . I have spoken to two humans ( not the chat bot ) and all they could suggest was deleting the app and reinstalling- which I did - it’s made no difference-

I reported back to member services that the suggested re-install did not fix the problem but it seems my complaint has disappeared into the “too difficult” black hole .

So I came back to the forum to see if anyone has an idea of how I can see my past sits in the app without a dashboard icon or the menu options of reviews and references or feedback .

@Silversitters I am also using free and volunteer-driven hospex exchanges like BeWelcome and Trustroots. Their software is not as messy and inconsistent and buggy as THS’s. Admittedly, their web-design and colours look awfully dated, but who cares about that?

But THS charges a hefty fee. Yet there are sooo many problems. And the only changes are about other stuff. (Well, at least the change that this thread is about was something that many had asked for.)

@Carla have spoken to member services again this evening and they say sitters don’t get a dashboard in the app …

I really am so confused …:weary::exploding_head:… I know that I could easily see reviews and feedback on the main menu previously but the options are not on the menu anymore…

@Silversitters I’m sorry this has caused so much confusion, I shared the screenshot of my screen on the app. I just checked my version of the app is 2.32.1 - you can check if you have the latest version in the app store.

I can see that you have a little suitcase icon at the bottom of your page that says ‘your sits’ Is it on there?

Feel free to send my screenshot and yours to Membership Services, if that helps and also check your version of the app. I hope that helps a bit more

@Katie Thank you for sharing your experience, I will pass that feedback on :slight_smile:

I can’t look at my sits on the app at all. When I click on the little suitcase, a little heart just spins forever. It’s been that way for weeks. I have to get out my laptop to pull up my sits.

@systaran That does sound like a pain, it also sounds like a little bug, so I would report it to Membership Services and also check you have the latest version of the app as well. I hope you get it resolved soon!

Hello, @Silversitters & @Jenny I will pop this thread here on here as well, as it looks like we are discussing the same issue there. Then we can share any updates on both threads.

@Carla I have the same version as you and an iPhone 11. I have the same app view (no dashboard) as @Silversitters. I do have a sit booked and, unlike @systaran , I can see the details when I click on the suitcase icon. Maybe that will help for whoever you report back to. I’m not willing to contact Membership Services as I use the website and app for different things and would likely go to my laptop for my dashboard.

Thank you @Snowbird Hopefully between us we can work out what is happening! :grin:

I, too, can’t see past sits on the app either @Carla. I get very frustrated as it shows past sitters (which I haven’t had since 2020) but not past sits which there are many and what I want to see. This is an issue that I’m sure other combined members face as THS assumes a combined member uses the Owner facility more which is not the case with me and other combined members I know.

1 Like

@Silversitters @Snowbird @systaran

I hope I can help with this further today, the team have come back as follows:

  • Sitters would need to open the Your Sits tab, and if they have an upcoming sit they will need to scroll to see their past sits.
  • Owners and Combined members can go to their dashboard for their past sits.

So, owners and combined members will see the app page as per my screenshot, where there will be a little house icon for ‘dashboard’. If you click here you can see your past sits:

Sitters will see a little suitcase icon ‘Your sits’ and if you click here you will see your past sits. Please scroll down to see your past sits:

For anyone that clicks on the little suitcase ‘Your sits’ and has any issues, there is a small glitch that has been reported, that affects some users, so you will need to report this issue to Membership Services as they can assist you with this.

I hope that helps clear up any confusion, Membership Services should have more information if you still need help.

Hello @temba I have copied this from the other thread discussing this, hopefully, it will help, if not please reach out to Membership Services as they can look into your account further :slight_smile:

Thanks @Carla

I have clicked on the suitcase and scrolled down there are no past sits on my app.

I’ve deleted and re-installed the app.

I’ve contacted member services on three occasions. Spoken to three different MS executives .

They have not been able to help.

They say they can’t replicate my issue .

@Silversitters I’m sorry that this is such an issue for you, what pain! I can see that @Jenny passed your details onto the Membership Services team, letting them know that this is an ongoing issue. Please look out for their email and feel free to drop us a DM if it does not get sorted and we can follow up for you again. I hope it gets resolved soon!

1 Like